Forum : Lws & Hebergeur-discount

Hébergement web, nom de domaine et serveur dédié.

Envoyé un Mailling List avec mon Serveur VPS M

Ici, parlez de vos serveurs VPS & dédié Linux.
utaku
Utilisateur Experimenté
Utilisateur Experimenté
Messages : 137
AntiSpam : - Non -

jeu. nov. 29, 2012 10:14 pm  

Bonjour,

J'ai une boutique E-Commerce fait avec prestashop, hébergé sur un serveur VPS M sur LWS .

Je voudrais savoir s'il m'était possible d'envoyé une mailling list via le serveur de mon site et depuis une adresse mail de mon site.

J'utilise ISPConfig , j'ai déjà crée des adresses mails, ... mais je ne sais pas comment envoyé une newsletter depuis mon Back Office de mon site.

J'ai bien un module Ps Newsletter qui donne la possibilité de le faire, il me dit qu'il à bel et bien envoyé la newsletter, mais personne ne la reçois.

Mon prestashop est configuré avec pour fonction : PHP Mail.

Je suis avec la derniere version 1.5.2 de prestashop, en allant dans client / SAV , tout en bas j'ai la possibilité de remplir certaine information mais je ne sais pas quoi y mettre

URL IMAP

Port IMAP

Utilisateur IMAP

Mot de passe IMAP

Alors pour l'url, j'avais mis imap.mondomaine.be et pour le port j'avais mis 587 et ensuite j'avais mis l'adresse mail ( crée via ispconfig ) en utilisateur ainsi que le mot de passe.

Mais cela ne fonctionne pas .

Voici le type d'erreur que j'ai droit :

TECHNICAL ERROR: unable to sync.

Details:
Error thrown: [object Object]
Text status: parsererror


Voilà donc ma question est simple, comment faire pour que cela fonctionne et surtout que dois je éventuellement configuré dans ISPconfig pour pouvoir utilisé mon serveur comme serveur d'envoye de mail ( smtp ? ).

Merci d'avance

Bien à vous

Johan

Ps : mon site est le suivant : http://www.entre-copines.be

Avatar de l’utilisateur
Damien - LWS
Modérateur
Modérateur
Messages : 123
AntiSpam : - Non -

ven. nov. 30, 2012 9:08 am  

Bonjour,

Les paramètres IMAP sont les suivants :
serveur imap.votre_domaine.com
ou l'adresse IP de votre VPS
Port : 143 (et non 587)
utilisateur : votre adresse mail
mot de passe : mot de passe créé sous ispconfig

Les paramètres SMTP :
serveur smtp.votre_domaine.com
ou l'adresse IP de votre VPS
Port : 25
utilisateur : votre adresse mail
mot de passe : mot de passe créé sous ispconfig

Dans tous les cas pour résoudre ce genre de problème il est préférable d'ouvrir un ticket d'incidence plutôt que de poster sur le FORUM. Notre équipe technique ne peut accéder à vos informations (compte client, type de formule, type de serveur ..) avec juste les informations délivrées plus haut.

cdt.
Damien
Service Technique LWS

Rubrique d'aide LWS : http://aide.lws.fr/
Les nouveautés : http://blog.lws-hosting.com/

Noms de domaine, hébergement web, serveurs dédiés, e-commerce, SMS par internet ...
Twitter : http://twitter.com/lwshosting

matdu58
Débutant
Débutant
Messages : 18
AntiSpam : - Non -

mer. déc. 19, 2012 9:59 am  

Salut Johan,

As-tu résolu ton problème car j'ai exactement le même (message d'erreur qui apparaît en lançant la synchronisation mail) ?
J'ai pourtant bien configuré avec les bonnes données...

Je trouve aussi bizarre que le champ mot de passe soit diffusé en clair et non pas masqué par des points ou astérisques par Prestashop (un peu limite niveau sécurité) !

Merci !
Mathieu

utaku
Utilisateur Experimenté
Utilisateur Experimenté
Messages : 137
AntiSpam : - Non -

mer. déc. 26, 2012 12:13 pm  

Salut Mathieu,

non malheureusement cela n'est pas encore résolu.
J'ai toujours le même soucis et je ne comprend pas pourquoi, j'ai même changer le port d'envoi des mail par 587 ( 25 par défault )
via la console SSH ( commande trouver sur le wiki ).
Mais rien ne change.

Je n'arrive toujours pas a rejoindre mon ISPConfig, même après avoir utiliser la commande pour rajouter le port 81 à iptable du firewall de mon serveur... mais rien n'y fait.
J'aimerais pouvoir désactivé se firewall via la consol SSH mais personne ne me répond lol ... secret d'état ?

et de plus maintenant j'ai dans paramètre avancé / information ( dans prestashop ) en bas dans paramètre secondaire : une erreur de magic quote ( que j'aimerais activé ) et pdo_msql ...

J'y comprend rien lol, je ne sais pas trop comment le régler

Bien à toi

johan

Avatar de l’utilisateur
Damien - LWS
Modérateur
Modérateur
Messages : 123
AntiSpam : - Non -

mer. déc. 26, 2012 2:28 pm  

Bonjour,

Pour ouvrir le port 81 dans le pare-feu activé sous ISPconfig, vous pouvez utiliser cette commande depuis une console SSH :
iptables -t filter -I PUB_IN -p tcp --dport 81 -j ACCEPT

Pour le problème de magic quote, vous pouvez éditer directement votre PHP.ini (http://wiki.lws-hosting.com/doku.php/co ... erveur_vps).

Pour tout autre question ouvrez directement un ticket d'incidence. Nos techniciens vous répondrons dans la journée.

cdt.
Damien
Service Technique LWS

Rubrique d'aide LWS : http://aide.lws.fr/
Les nouveautés : http://blog.lws-hosting.com/

Noms de domaine, hébergement web, serveurs dédiés, e-commerce, SMS par internet ...
Twitter : http://twitter.com/lwshosting

utaku
Utilisateur Experimenté
Utilisateur Experimenté
Messages : 137
AntiSpam : - Non -

ven. déc. 28, 2012 1:56 am  

Hello Damien,

merci pour ta réponse, j'ai déjà réussi a résoudre une partie de mon problème, concernant les magic quote ;)

Voila par contre quand je vais donc dans préférence avancé/information, sur mon prestashop

j'ai toujours cette erreur et je ne sais pas comment elle est arrivé, sachant que je n'ai rien toucher concernant ce truc lol

Paramètres requis: OK

Paramètres facultatifs: Veuillez consulter la/les erreur(s) suivante(s)

pdo_mysql

Aurais tu une idée de comment résoudre cela ?

En ce qui concerne le panel ISPConfig, je n'y est toujours pas accès, j'avais déjà fait la manip de " iptables -t filter -I PUB_IN -p tcp --dport 81 -j ACCEPT "
sous la console mais rien y change ^^'

J'aimerais savoir comment désactiver ce fichu firewall dans la console, mais je n'ai trouver aucune information à ce sujet, et personne ne semble savoir comment faire, sauf en infogérance mais pas les moyens ;) et surtout pas pour une chose que je dont je pourrais faire la manip ( si je la connaissais :p ).

merci d'avance

Johan

Avatar de l’utilisateur
Damien - LWS
Modérateur
Modérateur
Messages : 123
AntiSpam : - Non -

ven. déc. 28, 2012 8:47 am  

Bonjour,

Pour désactiver totalement le pare-feu :
iptables -P INPUT ACCEPT
iptables -P FORWARD ACCEPT
iptables -P OUTPUT ACCEPT
iptables -F

Pour le message "mysql_pdo", il s'agit d'un paramètre optionnel (Paramètres facultatifs: Veuillez consulter la/les erreur(s) suivante(s)).
Pour l'activation de l'option :
http://www.php.net/manual/fr/pdo.installation.php

cdt.
Damien
Service Technique LWS

Rubrique d'aide LWS : http://aide.lws.fr/
Les nouveautés : http://blog.lws-hosting.com/

Noms de domaine, hébergement web, serveurs dédiés, e-commerce, SMS par internet ...
Twitter : http://twitter.com/lwshosting

utaku
Utilisateur Experimenté
Utilisateur Experimenté
Messages : 137
AntiSpam : - Non -

ven. déc. 28, 2012 12:52 pm  

Hello Damien,

Un grand merci as toi pour ton aide.
J'ai donc pu corrigé les erreurs suivante : Magic quote et pdo_mysql
et j'ai donc pu également désactiver le firewall.

J'ai corriger l'erreur pdo_mysql en rajoutant ces lignes dans les fichiers php.ini

; Load PDO MySQL extension
extension=pdo.so
extension=pdo_mysql.so
extension=php_pdo_mssql.dll

Bon tout mes soucis sont bientôt régler.

Pour le panel ISPConfig, j'arrive enfin à afficher la page d'accueil, cependant je n'ai pas la possibilité de me logger car les emplacements pour y mettre sont login et pass sont absente.
Voici les erreurs que je continue d'avoir.


Deprecated: Function set_magic_quotes_runtime() is deprecated in /usr/local/ispconfig/interface/lib/config.inc.php on line 48

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /usr/local/ispconfig/interface/lib/config.inc.php:48) in /usr/local/ispconfig/interface/lib/app.inc.php on line 76

Alors l'un des trucs est en rapport avec les magic quotes , ce que je trouve bizarre, pour faire fonctionner les magic quotes sur son site prestashop, faut il uniquement les activer dans le fichier php.ini de apache ou alors également dans celui des dossier cgi et cli ?

pour l'autre erreur, j'y comprend rien lol.

Merci d'avance

Johan

  •   Information
  • Qui est en ligne ?

    Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité