Forum : Lws & Hebergeur-discount

Hébergement web, nom de domaine et serveur dédié.

Mauvais formatage à l'export de la base sql

Ici, parlez de développement Asp, Php, Asp.net, Mysql / Access, / sql serveur, de bases de données et de développement.
Avatar de l’utilisateur
Yoann - LWS
Modérateur
Modérateur
Messages : 79
AntiSpam : - Non -

ven. déc. 16, 2016 9:30 am  

Bonjour,

Le problème que vous pouvez rencontrer peut également être relatif au fait que votre version Mysql présent en local est différent de la version présent sur nos serveurs.
Nous somme en version 5.5 alors que votre version est en 5.7 ce qui peut alors expliquer votre problème.

Cordialement.
Yoann
Service technique LWS
http://www.lws.fr

Rubrique d'aide LWS : http://aide.lws.fr
Les nouveautés : http://blog.lws-hosting.com

Noms de domaine, hébergement web, serveurs dédiés, e-commerce, SMS par internet ...

gpinpin
Débutant
Débutant
Messages : 27
AntiSpam : - Non -
Localisation : Lyon
Contact :

sam. déc. 17, 2016 2:50 pm  

Bonjour
Avant de voir ce que j'ai en mysql il faut regarder les imports.
Et les importions que je fais à partir de la base sql sont differentes depuis environ le 29 novembre comme je l'explique.
Ceci bien avant que je l'importe dans ma base en local.

En cherchant un peu et en listant les modifs des versions successives de Phpmyadmin
je peux lire ceci:
Code de Duplication # 12508
et en commentaire en lisant plus approfondi
je vois aussi ceci
/**
* Add slashes before "'" and "\" characters so a value containing them can
* be used in a sql comparison.
*
* @param string $a_string the string to slash
* @param bool $is_like whether the string will be used in a 'LIKE' clause
* (it then requires two more escaped sequences) or not
* @param bool $crlf whether to treat cr/lfs as escape-worthy entities
* (converts \n to \\n, \r to \\r)
* @param bool $php_code whether this function is used as part of the
* "Create PHP code" dialog
*
* @return string the slashed string
*
* @access public
*/

d'autre part cela rejoint un bug répertorié au mois d'aout:
\ n exporté en tant que \\ n # 12781

suivre ce lien
https://github.com/phpmyadmin/phpmyadmin/issues/12781

Je pense donc que chez vous ce bug n'est pas fixé

Cordialement
Gpinpin

abvsbopb
Débutant
Débutant
Messages : 4
AntiSpam : - Non -

mar. déc. 20, 2016 11:54 am  

Bonjour,
je ne m' étais jamais inscrit sur ce forum....je viens de le faire!
moi aussi je confirme que LWS a fait quelques modifs qui font qu' à l' exportation on se retrouve avec des caractères d' échappement qui corrompent quelques tables.....
Ils on osé me dire que ce n''était chez moi en local que j' avais ce problème et que toute ré_importation de leur bd chez eux ne poserait pas de souci. J' ai émis franchement des doutes......

Pour réussir en local, mon importation il a fallu que je procède au remplacement de:\" par ", puis \\r\\n remplacé par \r\n, et en fin des \\ remplacé par des \.

qu'ils osent dire qu(ils n'ont fait aucune modif est inacceptable ( jai bien vu changer leur version de serveur depuis le mois d' Octobre!!!)

Avatar de l’utilisateur
Yoann - LWS
Modérateur
Modérateur
Messages : 79
AntiSpam : - Non -

mar. déc. 20, 2016 4:17 pm  

Bonjour,

J'ai transmis votre demande au service supérieur.
Des tests vont être effectués.

Cordialement.
Yoann

Service technique LWS

http://www.lws.fr



Rubrique d'aide LWS : http://aide.lws.fr

Les nouveautés : http://blog.lws-hosting.com



Noms de domaine, hébergement web, serveurs dédiés, e-commerce, SMS par internet ...

gpinpin
Débutant
Débutant
Messages : 27
AntiSpam : - Non -
Localisation : Lyon
Contact :

mar. déc. 20, 2016 10:24 pm  

Bonsoir
Ce qui sous entend que vous n'avez pas encore fait de tests....

Bon on va relativiser et merci mais reconnaissez que c'est dur de vous comprendre dans votre inertie..

Comme je l'ai souligné ce bug date a été répertorié au mois d'aout. C'est ce que j'ai cru comprendre en lisant des spécialistes.... que je ne suis pas moi même mais je sais faire un constat

Cordialement
Gpinpin

PS @abvsbopb comment avez vous opéré pour remplacer les \\n par \n car j'ai essayé avec notepad++ et je n'ai pas réussi

Gp

abvsbopb
Débutant
Débutant
Messages : 4
AntiSpam : - Non -

mer. déc. 21, 2016 2:34 pm  

Bonjour,
Avec notepad++ j'ai exécuté plusieurs fois ( boucle...) les remplacements.

par exemple j'avais \\" il faut donc exiger le remplacement de \" par " en exécutant 2 fois les remplacements....je l' ai fait jusqu'à avoir 0 occurrences de remplacement...( depuis la première ligne du fichier jusqu'à la dernière ligne)
Pareil pour tous les autres remplacements.

Une fois fini j' ai zippé ma base et je l'ai importé( j'avais aupravant vidé toutes mes tables; j'avais pris la précaution de conserver une copie de ma base locale qui datait d' un mois...)

cordialement,

gpinpin
Débutant
Débutant
Messages : 27
AntiSpam : - Non -
Localisation : Lyon
Contact :

mer. déc. 21, 2016 5:49 pm  

Bonjour et merci de cette recette ;)
Pour l'instant je passe par le PCA du forum et ca fonctionne mais j'aime bien avoir une roue de secours

A+

abvsbopb
Débutant
Débutant
Messages : 4
AntiSpam : - Non -

jeu. déc. 22, 2016 8:50 am  

Bonjour,
je ne fréquente pas assez les forum.....et je ne sais ce que vous désignez par PCA.
Je suis d'un certain âge et ayant fait autrefois mon service militaire je sais ce que désignait alors un PCA !!!!!!
Vous allez donc m' apprendre ce que vous désignez par "PCA du forum " !
Merci de votre réponse.
Cordialement,


PS:- j' ai fait les remplacement de \\r\\n par \r\n ( vous aviez bien sur compris.)
- Je me demande si les informaticiens de chez LWS ( Niveau N+1, voire N+2, ) se sont vraiment penchés sur le problème......
- Avez vous remarqué que quand ils ne répondent pas sur le forum, ils demandent de passer par les tickets d'incidents. Ce n'est pas pour autant qu'ils répondent mais ça reste entre eux et leurs clients !

gpinpin
Débutant
Débutant
Messages : 27
AntiSpam : - Non -
Localisation : Lyon
Contact :

ven. déc. 23, 2016 11:11 am  

Bonjour
Le pca est en fait l'administration du forum après je passe par maintenance et sauvegarde et là le formatage est bon
Ça n'a pas l'air de bouger beaucoup du côté de LWS
A+

Avatar de l’utilisateur
Yoann - LWS
Modérateur
Modérateur
Messages : 79
AntiSpam : - Non -

lun. déc. 26, 2016 2:14 pm  

Bonjour,

Nous avons fait des tests approfondis et nous avons effectivement pu constater un problème sur l'exportation des bases de données.

Notre effectif est réduit pendant les fêtes de fin d'années, ce qui rend le délai de résolution un peu plus long qu'à l'accoutumée.

Ce problème sera réglé en fin de semaine.

Nous nous excusons de cette gène occasionnée.

Cordialement.
Yoann

Service technique LWS

http://www.lws.fr



Rubrique d'aide LWS : http://aide.lws.fr

Les nouveautés : http://blog.lws-hosting.com



Noms de domaine, hébergement web, serveurs dédiés, e-commerce, SMS par internet ...

  •   Information
  • Qui est en ligne ?

    Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 2 invités