Forum : Lws & Hebergeur-discount

Hébergement web, nom de domaine et serveur dédié.

Courriel envoyé via PHP non reçu par certains destinataires

Ici, parlez de développement Asp, Php, Asp.net, Mysql / Access, / sql serveur, de bases de données et de développement.
Quejd
Débutant
Débutant
Messages : 8
AntiSpam : - Non -

dim. déc. 28, 2014 9:09 pm  

Bonjour,

j'utilise la commande mail() pour envoyer des courriels de confirmation d'inscription, mais certains destinataires ne les reçoivent pas (exemple chez @orange.fr ou @ac-academie.fr). Ces envois n'arrivent même pas en tant que spam... est-ce contournable ou bien les mails issus de chez LWS via PHP sont filtrés par ces hébergeurs destinataires ? Est-ce un problème de contenu mail incomplet, où puis-je alors trouver la syntaxe complète ?

Mon code est le suivant :

<?php
$mail = $_POST['mel'];
if (!preg_match("#^[a-z0-9._-]+@(hotmail|live|msn).[a-z]{2,4}$#", $mail)) {$passage_ligne = "\r\n"; } else { $passage_ligne = "\n"; }
$message_txt = "Bonjour, **********";
$message_html = "Bonjour, **********";
$boundary = "-----=".md5(rand());
$sujet = "Confirmation d'inscription à *****.fr";
$header = "From: \"Message automatique de ******.fr\" <******@*****.fr>".$passage_ligne;
$header.= "Reply-To: \"Ceci n'est pas une adresse valide\" <******@*****.fr>".$passage_ligne;
$header.= "MIME-Version: 1.0".$passage_ligne;
$header.= "Content-Type: multipart/alternative;".$passage_ligne." boundary=\"$boundary\"".$passage_ligne;
$message = $passage_ligne."--".$boundary.$passage_ligne;
$message.= "Content-Type: text/plain; charset=\"ISO-8859-1\"".$passage_ligne;
$message.= "Content-Transfer-Encoding: 8bit".$passage_ligne;
$message.= $passage_ligne.$message_txt.$passage_ligne;
$message.= $passage_ligne."--".$boundary.$passage_ligne;
$message.= "Content-Type: text/html; charset=\"ISO-8859-1\"".$passage_ligne;
$message.= "Content-Transfer-Encoding: 8bit".$passage_ligne;
$message.= $passage_ligne.$message_html.$passage_ligne;
$message.= $passage_ligne."--".$boundary."--".$passage_ligne;
$message.= $passage_ligne."--".$boundary."--".$passage_ligne;
mail($mail,$sujet,$message,$header);
?>

Bien à vous.

Avatar de l’utilisateur
Sylvain - LWS
Modérateur
Modérateur
Messages : 616
AntiSpam : - Non -

lun. déc. 29, 2014 4:02 pm  

Bonjour,

Je vous inviterai à vérifier si le mail envoyés via cette fonction mail php n'est pas bloqué.
Vous pouvez visualiser les mails envoyés depuis cette fonction mail php dans votre espace client LWS et la rubrique "administration email" puis en cliquant sur le lien "Stats des mails envoyés avec la fonction mail de Php() et stats global du compte", depuis cette rubrique il vous sera possible de visualiser les mails envoyés qui retourne une erreur.
Sylvain
Service technique LWS
http://www.lws.fr

Rubrique d'aide LWS : http://aide.lws.fr
Les nouveautés : http://blog.lws-hosting.com

Noms de domaine, hébergement web, serveurs dédiés, e-commerce, SMS par internet ...

Quejd
Débutant
Débutant
Messages : 8
AntiSpam : - Non -

lun. déc. 29, 2014 8:12 pm  

Bonjour,

ayant lu les messages précédents sur le forum j'avais déjà visualisé la page que vous me conseillez :

Il y a eu 0 erreur(s) d'envois de mail avec la fonction mail() de php depuis les 15 derniers jours
Il y a eu 0 e-mail(s) en erreur(s) non envoyé(s) par la fonction mail().

Depuis j'ai testé l'envoi sur une adresse @orange.fr > n'arrive pas ; sur une adresse @laposte.net > arrive.

Ils partent bien mais sont filtrés (?) par le fournisseur du destinataire.

Pour l'instant je contourne le problème, mais j'aimerai comprendre/savoir.

Bonne fin d'année.

Avatar de l’utilisateur
Sylvain - LWS
Modérateur
Modérateur
Messages : 616
AntiSpam : - Non -

mar. déc. 30, 2014 9:44 am  

Bonjour,

pourriez vous me communiquer votre nom de domaine ?
Sylvain
Service technique LWS
http://www.lws.fr

Rubrique d'aide LWS : http://aide.lws.fr
Les nouveautés : http://blog.lws-hosting.com

Noms de domaine, hébergement web, serveurs dédiés, e-commerce, SMS par internet ...

Quejd
Débutant
Débutant
Messages : 8
AntiSpam : - Non -

jeu. janv. 08, 2015 7:35 pm  

MP envoyé et toujours pas de réponse de mon coté.

Par contre à force d'essais j'en déduis que vos adresses IP sont filtrés, voilà un retour de mail refusé :

This is the mail system at host mailler18.lws-hosting.com.
I'm sorry to have to inform you that your message could not
be delivered to one or more recipients. It's attached below.
For further assistance, please send mail to postmaster.
If you do so, please include this problem report. You can
delete your own text from the attached returned message.
The mail system
<*****.*****@ac-amiens.fr>: host mx2.ac-amiens.fr[1xx.1xx.4x.8x] said: 554

Avoir un service messagerie et ne pas pouvoir s'en servir, c'est plutôt gênant...

Merci.
5.7.1 <admin@*****.fr>: Sender address rejected: Pas de message commercial
sans accord prealable du destinataire - HB - 03/12/2013 (in reply to RCPT
TO command)

Avatar de l’utilisateur
Karen - LWS
Modérateur
Modérateur
Messages : 1359

ven. janv. 09, 2015 2:08 pm  

Bonjour,

Sylvain est en congés cette semaine, d'où le fait que vous n'ayez pas eu de réponse.

Nous vous rappelons que ce forum n'est pas notre support technique, je vous conseille donc de passer par votre espace client directement afin qu'un technicien puisse répondre à votre problématique.

Pour ouvrir un ticket, rendez dans la rubrique "Support", une réponse vous sera faite dans les 4 heures ouvrées qui suivent l'envoi du ticket.

Cordialement,
Karen
Service clients LWS

Rubrique d'aide LWS : http://aide.lws.fr
Les nouveautés : http://blog.lws-hosting.com

Noms de domaine, hébergement web, serveurs dédiés, e-commerce, SMS par internet ...

Quejd
Débutant
Débutant
Messages : 8
AntiSpam : - Non -

lun. janv. 12, 2015 4:20 pm  

Bonjour,

donc le serveur mail dont dépend mon domaine est filtré.
N'ayant pas fait d'envois abusifs, ni de spam, ni de choses illégales, suis-je à l'origine de ce blocage ?
Est-ce parce que je suis sur un serveur mutualisé qui peut-être hébergerait un domaine qui aurait posé problème ?
Dois-je passer par un serveur dédié pour être certain de ne plus rencontrer ce problème ?
Merci pour votre écoute.

Avatar de l’utilisateur
Sylvain - LWS
Modérateur
Modérateur
Messages : 616
AntiSpam : - Non -

mar. janv. 13, 2015 10:37 am  

Bonjour,

étant sur un serveur mutualisée, un autre client a pu provoqué ce souci.
Le passage sur un serveur VPS, vous permettra d'avoir une adresse IP qui vous sera dédié.
Sylvain
Service technique LWS
http://www.lws.fr

Rubrique d'aide LWS : http://aide.lws.fr
Les nouveautés : http://blog.lws-hosting.com

Noms de domaine, hébergement web, serveurs dédiés, e-commerce, SMS par internet ...

  •   Informations
  • Qui est en ligne

    Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 2 invités