Forum : Lws & Hebergeur-discount

Hébergement web, nom de domaine et serveur dédié.

simplexml_load_file ne fonctionne pas sur une url distante

Ici, parlez de développement Asp, Php, Asp.net, Mysql / Access, / sql serveur, de bases de données et de développement.
dredtrake
Débutant
Débutant
Messages : 1
AntiSpam : - Non -

dim. janv. 05, 2014 11:11 pm  

Bonjour à tous,
j'ai besoin de loader un flux rss via php,
chez moi aucuns soucis, (localhost),
par contre sur mon mutualisé rien à faire ça le load pas, et j'ai pas de retour.

le code que j'utilise est le suivant :
celui la fonctionne :

$rss = simplexml_load_file("rss.xml");
if(!$rss){
echo "load error";
}

celui-la non :

$rss = simplexml_load_file("http://uneUrlNonLocale/rss.xml");
if(!$rss){
echo "load error";
}

file_get_contents ne fonctionne pas non plus sur une url distante.
j'ai mis les directives suivante dans le .htaccess :
php_flag "allow_url_fopen" "On"
php_flag "allow_url_include" "On"
mais pas mieux.

avez-vous une idée d'ou cela pourrais venir ?

Une bien bonne soirée.

Avatar de l’utilisateur
Vincent - LWS
Modérateur
Modérateur
Messages : 84
AntiSpam : - Non -

mar. janv. 07, 2014 8:23 am  

Bonjour,

Il est possible qu'il y eu un problème de résolution de nom de domaine sur votre hébergement.

Si votre flux rss est disponible sous une url de type http://ADRESSE_IP/rss.xml, vous pouvez tester cette forme. Si cela marche, il s'agit alors d'un problème de résolution de dns.

Je vous invite dans tout les cas à ouvrir un ticket technique depuis votre espace client ou à nous communiquer votre nom de domaine.

Cordialement.

  •   Information
  • Qui est en ligne ?

    Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 3 invités