Forum : Lws & Hebergeur-discount

Hébergement web, nom de domaine et serveur dédié.

Zend Opcache ? dispo?

Ici, parlez de vos serveurs VPS & dédié Linux.
utaku
Utilisateur Experimenté
Utilisateur Experimenté
Messages : 137
AntiSpam : - Non -

mer. juil. 10, 2013 5:32 pm  

Bonjour,

Je sollicite vôtre aide afin de voir s'il y a la possibilité d'installer cette extension de pecl sur mon VPS L

J'ai vu cet article : http://www.php.net/manual/en/opcache.installation.php

C'est donc intégré directement avec PHP 5.5 et il y aurait la possibilité de l'installer par extention pecl.

J'ai déjà mis à jours ma version de PhP via la console SSH , je suis donc passer de la version 5.3.2 à 5.3.6
Je ne comprend pas pourquoi nous n'avons pas directement le droit d'avoir la version 5.5 ?

Comment faire pour l'installer ? quel est la commande SSH à faire ?

Voici pourquoi j'aimerais l'avoir : http://www.prestashop.com/blog/fr/votre ... d-opcache/

Sinon voici les sources directement pour le Zend Opcache : http://pecl.php.net/package/ZendOpcache

Mais la il faudrait faire l'installation manuellement, et j'ignore la procédure

Merci d'avance

Johan

Avatar de l’utilisateur
Damien - LWS
Modérateur
Modérateur
Messages : 123
AntiSpam : - Non -

jeu. juil. 11, 2013 9:17 am  

Bonjour,

Pour mettre à jour votre version de PHP, je vous invite à utiliser les dépôts DOTDEB :
http://www.dotdeb.org/instructions/

Ensuite pour installer une extention PHP avec pecl, il suffit généralement d'utiliser la commande :
pecl install <mon_module>

Puis éventuellement ajouter le lien vers le fichier .so dans votre ficher php.ini.

Dans tous les cas il est judicieux de trouver une documentation sur le sujet.

Avant d'utiliser pecl, vérifiez que le paquet php5-dev est bien installé :
aptitude install php5-dev

cdt.
Damien
Service Technique LWS

Rubrique d'aide LWS : http://aide.lws.fr/
Les nouveautés : http://blog.lws-hosting.com/

Noms de domaine, hébergement web, serveurs dédiés, e-commerce, SMS par internet ...
Twitter : http://twitter.com/lwshosting

utaku
Utilisateur Experimenté
Utilisateur Experimenté
Messages : 137
AntiSpam : - Non -

ven. juil. 12, 2013 10:04 am  

Bonjour Damien,

Merci pour ta réponse, je n'ai toujours pas réussi à installer le Zend Opcache :p

Voici ce que j'ai fais :

J'ai suivi le tuto du lien que tu m'as fournis, et tout c'est très bien dérouler, ensuite j'ai ajouter au source.list ceci :

http://wiki.lws-hosting.com/doku.php/de ... d_EWG1Bqmo

Ensuite j'ai utiliser les commandes suivante : http://wiki.lws-hosting.com/doku.php/in ... d_Ed21Bqmo

J'ai donc utiliser les commandes pour mettre à jours la liste des dépots... tout c'est très bien passé.

Ensuite, j'ai voulu faire un : apt-get upgrade , et la il ma trouver 128 mise à jours à faire , Oo" sa ma paru énorme mais j'ai lancé la procédure, tout ce télécharge sans problème, mais ne s'installe pas.
Après le téléchargement, il fait la lecture du CHANGELOG et me l'affiche ou je ne sais pas trop quoi, me parle d'un truc instable... et rien ne fonctionnais, j'ai juste réussi à faire un CTRL+C et j'ai quitté le truc.

Ensuite , j'ai voulu faire un : apt-get dist-upgrade , et la encore pire il ma trouver 528 mise à jours, dont 128 nouvelles installe et 13 suppressions, Oo"" , j'ai lancé donc la procédure, mais j'arrivais au même résultat.

J'ai tenter ensuite plusieurs commande du style pecl install Opcache, ....et plein d'autres mais rien ne fonctionne car il ne trouve rien ..

J'ai bien le aptitude install php5-dev d'installer, il n'y pas de soucis.

Comment ou que dois je faire pour l'installer ?
Est ce que finalement c'est une bonne choses que je n'ai pas pu faire les grosses mise à jours ?
Bloqué vous l'installation éventuel de PHP 5.5 ?

J'ai juste peur de faire une mauvaise manipulation et que mon serveur ne fonctionne plus :(

Merci pour votre future réponse,
Bien à vous

Johan

utaku
Utilisateur Experimenté
Utilisateur Experimenté
Messages : 137
AntiSpam : - Non -

ven. juil. 12, 2013 10:51 am  

Bon Finalement, j'ai refais quelques test et autres et j'ai réussi ( je pense )

Voila comment j'ai procédé pour ceux que sa intéresse :

Après avoir fait les manips de mon post précédent , j'ai essayer de faire un

pecl download-all : => au début il m'affichait qu'il ne s'avait rien DL mais au final, il me la tout de même fait Oo' étrange donc .

Par contre il ne voulait absolument pas me télécharger le ZendOpcache, qu'il trouvait bien ...

j'ai donc été ici : http://pecl.php.net/package/ZendOpcache

et j'ai télécharger la dernier version stable, que j'ai ensuite placer sur le serveur à l'adresse suivante : root/ici

Ensuite j'ai donc faite cette commande : pecl install root/zendopcache-7.0.2.tgz

l'installation c'est dérouler sans aucun soucis, une fois installer il faut aller sur le serveur et rajouter la ligne suivant dans le fichier php.ini ce trouvant dans etc/php5/apache ou cli

zend_extension=opcache.so

j'ai également rajouter c'est information de configuration :

opcache.memory_consumption=128
opcache.interned_strings_buffer=8
opcache.max_accelerated_files=4000
opcache.revalidate_freq=60
opcache.fast_shutdown=1
opcache.enable_cli=1

Voila installation fini , par contre je ne retrouve pas les informations de Zend Opcache dans mon php info

faut il que je reboot le serveur ?

bien à vous

johan

bossboz
Débutant
Débutant
Messages : 1
AntiSpam : - Non -

mar. juil. 23, 2013 3:02 pm  

Salut utaku,
moi même ayant ouvert une boutique PrestaShop j'ai utilisé tes instructions pour télécharger et installer OPcache mais ayant mis le fichier tgz dans le dossier root putty me rend toujours un message " install failed".
Pourrais-tu m'aider?
J'ai PHP 5.3 et je ne sais pas comment updater vers 5.5 et je crois que on peut tout de même installer opcache sur 5.3?

utaku
Utilisateur Experimenté
Utilisateur Experimenté
Messages : 137
AntiSpam : - Non -

mer. juil. 24, 2013 1:07 am  

Hello,

il n'y a pas de soucis pour l'installer sur un php 5.3, si tu as bien suivi les instructions en haut, et rajouter les dépots aux sources.list et fait la maj en consol ssh de la liste des dépost...

alors il te reste plus grand chose à faire

Essaye de faire les commandes suivantes :

cd root
pecl install nomdufichier.thz

Si rien ne se passe alors essaye de décompresser l'archive avec la commande suivante :

tar -zvxf fichier.tgz

** J'éditerais plustard, quand mon serveur sera plus down

  •   Information
  • Qui est en ligne ?

    Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité