Forum : Lws & Hebergeur-discount

Hébergement web, nom de domaine et serveur dédié.

Configuration Sendmail sur Debian 8

Ici vous pouvez poser vos questions techniques, les problemes que vous rencontrez (publication de votre site, configuration dns des domaines...)
Oliv59
Débutant
Débutant
Messages : 23
AntiSpam : - Non -

mar. nov. 15, 2016 10:32 pm  

Hello ici,

Voici mon souci : Je tente désespérément de configurer Sendmail (via le panel Webmin installé sur mon VPS, ou via les fichiers de config si nécessaire, sans problème) sous Debian8 sur mon VPS 32357. Impossible de le configurer pour qu'il envoie des mails.
D'après ce que j'avais lu, un simple compte utilisateur linux suffisait, mais ca ne marche pas dans mon cas, je dois louper quelque chose.
Donc, j'ai un compte utilisateur Olivier, avec son mot de passe.
La commande " echo "Subject: test" | sendmail -v xxxx@yyyy.fr" fonctionne correctement, je recois le mail sans soucis.
J'ai paramétré mon script PHP d'envoi de mails avec les valeurs suivantes :

MAIL_DRIVER=smtp
MAIL_HOST=localhost
MAIL_USERNAME=Olivier
MAIL_PASSWORD=MonMotDePasse
MAIL_ENCRYPTION=null

Mais impossible. Mon script PHP trouve bien le serveur sendmail (je pense), mais impossible de s'y connecter, j'ai toujours une erreur d'authentification.
J'ai tenté comme nom d'utilisateur : Olivier / Olivier@vps32357/ Olivier@vps32357.lws-hosting.com / Olivier@mondomaine.fr, sans plus de succes ...
Aussi, je ne peux pas faire de telnet sur ce serveur sur le port 25, alors que le firewall LWS (https://panel.lws.fr/idlws_vps_firewall.php5) m'indique que le port 25 est ouvert ??
Pour info, j'ai aussi activé le relais SMTP dans mon espace lws.
Que puis-je tester, vérifier, essayer, pour avancer dans ce souci et le résoudre ?
Merci d'avance pour votre aide.
Oliv.

Avatar de l’utilisateur
Sylvain - LWS
Modérateur
Modérateur
Messages : 616
AntiSpam : - Non -

mer. nov. 16, 2016 9:15 am  

Bonjour,

je vous inviterai à indiquer comme "MAIL_USERNAME" l'adresse email complète associé à votre domaine et comme MAIL_HOST l'adresse IP de votre VPS.
Cette configuration devrait vous permettre d'effectuer ces envoies de mails sans souci.
Sylvain
Service technique LWS
http://www.lws.fr

Rubrique d'aide LWS : http://aide.lws.fr
Les nouveautés : http://blog.lws-hosting.com

Noms de domaine, hébergement web, serveurs dédiés, e-commerce, SMS par internet ...

Oliv59
Débutant
Débutant
Messages : 23
AntiSpam : - Non -

mer. nov. 16, 2016 1:06 pm  

En mettant l'ip du serveur, il me dit qu'il ne peut pas se connecter au serveur, adresse inaccessible.
En mettant le nom complet, Olivier@visite360.immo, même message d'erreur d'authentification...

Avatar de l’utilisateur
Sylvain - LWS
Modérateur
Modérateur
Messages : 616
AntiSpam : - Non -

jeu. nov. 17, 2016 9:54 am  

Bonjour,

vous avez quelle erreur exactement, lorsque vous indiquez votre adresse email complète ?
Avez vous bien un service écoutant sur le port 25 ou 587 sur votre VPS car ces ports serait fermés, ce qui expliquerait le souci de connexion au serveur SMTP via l'adresse IP de votre VPS.
Vous pouvez visualiser si un port est ouvert sur un VPS depuis ce lien par exemple : http://www.yougetsignal.com/tools/open-ports/
Sylvain
Service technique LWS
http://www.lws.fr

Rubrique d'aide LWS : http://aide.lws.fr
Les nouveautés : http://blog.lws-hosting.com

Noms de domaine, hébergement web, serveurs dédiés, e-commerce, SMS par internet ...

Oliv59
Débutant
Débutant
Messages : 23
AntiSpam : - Non -

jeu. nov. 17, 2016 1:15 pm  

En mettant l'adresse mail complète :
"Failed to authenticate on SMTP server with username "Olivier@visite360.immo" using 1 possible authenticators".

Pour la seconde question, ça ressemble furieusement à ce que j'ai mis dans mon premier post :
"Aussi, je ne peux pas faire de telnet sur ce serveur sur le port 25, alors que le firewall LWS (https://panel.lws.fr/idlws_vps_firewall.php5) m'indique que le port 25 est ouvert ??"

Non ?

Avatar de l’utilisateur
Sylvain - LWS
Modérateur
Modérateur
Messages : 616
AntiSpam : - Non -

ven. nov. 18, 2016 4:33 pm  

Bonjour,

Le port 25 est ouvert sur votre VPS actuellement, la transmission de données via ce port devrait pouvoir s’effectuer normalement.
par contre sur l'erreur d'authentification sur l'envoi de mail, je ne visualise pas vraiment d’où cela pourrait venir directement, je suis désolé.
Je vous inviterai a vérifier si une authentification par mot de passe est bien activé sur votre script.
Sylvain
Service technique LWS
http://www.lws.fr

Rubrique d'aide LWS : http://aide.lws.fr
Les nouveautés : http://blog.lws-hosting.com

Noms de domaine, hébergement web, serveurs dédiés, e-commerce, SMS par internet ...

Oliv59
Débutant
Débutant
Messages : 23
AntiSpam : - Non -

dim. nov. 20, 2016 8:46 pm  

Sylvain, vous m'avez déjà dépanné par le passé, et je vous en ai remercié. Mais la, sérieusement ?

Sylvain - LWS a écrit:
> Bonjour,
>
> Le port 25 est ouvert sur votre VPS actuellement, la transmission de
> données via ce port devrait pouvoir s’effectuer normalement.
Je vous ai donné VPS, vous avez l'IP, vous avez toutes les informations. Essayez par vous meme un telnet dessus, vous verrez qu'il n'y a aucune réponse ...


> par contre sur l'erreur d'authentification sur l'envoi de mail, je ne
> visualise pas vraiment d’où cela pourrait venir directement, je suis
> désolé.
> Je vous inviterai a vérifier si une authentification par mot de passe est
> bien activé sur votre script.
Oui, justement, c'est bien le souci, j'active l'authentification SMTP dans le framework utilisé (Laravel), et impossible de le faire fonctionner ...
C'est un souci de config sendmail, ou de mon serveur en général, c'est pour ca que je vous demande de l'aide.

Avatar de l’utilisateur
Sylvain - LWS
Modérateur
Modérateur
Messages : 616
AntiSpam : - Non -

lun. nov. 21, 2016 5:48 pm  

Bonjour,

j'ai regarder la configuration de ce service sur votre VPS, je n'ai pas visualisé de souci particulier sur celui-ci.
Malheureusement, je ne soit pas d'ou viendrait ce problème, je suis désolé.
Je vous inviterai à vous rapprochez de l'éditeur du framework utilisé afin de voir avec eux si il n'aurait pas un souci sur celui-ci.
Sylvain
Service technique LWS
http://www.lws.fr

Rubrique d'aide LWS : http://aide.lws.fr
Les nouveautés : http://blog.lws-hosting.com

Noms de domaine, hébergement web, serveurs dédiés, e-commerce, SMS par internet ...

Oliv59
Débutant
Débutant
Messages : 23
AntiSpam : - Non -

lun. nov. 21, 2016 6:23 pm  

Sachant que ca fonctionne en utilisant un autre serveur SMTP ?
Qui utilise lui aussi une authentification ?
Je suis perplexe sur la faute de framework dans ce cas ...
Accessoirement, telnet sur port 25 toujours impossible.

Avatar de l’utilisateur
Sylvain - LWS
Modérateur
Modérateur
Messages : 616
AntiSpam : - Non -

mer. nov. 23, 2016 9:11 am  

Bonjour,

une requête telnet sur le port 25 sur votre VPS ne retourne pas d'erreur, cette action est possible.
Votre souci doit venir d'un problème au niveau du paramètrage de sendmail directement.
Je me permet de vous communiquer une documentation sur sendmail qui devra vous aidez à résoudre ce souci :
http://www.sendmail.org/~ca/email/auth.html
Sylvain
Service technique LWS
http://www.lws.fr

Rubrique d'aide LWS : http://aide.lws.fr
Les nouveautés : http://blog.lws-hosting.com

Noms de domaine, hébergement web, serveurs dédiés, e-commerce, SMS par internet ...

  •   Informations
  • Qui est en ligne

    Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 3 invités