Forum : Lws & Hebergeur-discount

Hébergement web, nom de domaine et serveur dédié.

PB de CHARSET

Ici vous pouvez poser vos questions techniques, les problemes que vous rencontrez (publication de votre site, configuration dns des domaines...)
Jules66
Débutant
Débutant
Messages : 3
AntiSpam : - Non -

jeu. janv. 14, 2016 10:29 pm  

Bonjour,
J'ai récemment transféré des pages html et php sur une site hébergé par LWS.
Ces pages étaient au préalable enregistrées avec l'encodage RTF-8 avant transfert (via LWS PANEL).
Or, je n'arrive pas à avoir à la fois les bons caractères dans le code et dans la page publiée... les lettres avec accent sont toutes remplacées par un point d'interrogation.

J'ai pourtant écrit dans le "head" de la page index.php le code suivant :
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />

Merci de votre aide.

Avatar de l’utilisateur
Sylvain - LWS
Modérateur
Modérateur
Messages : 674
AntiSpam : - Non -

ven. janv. 15, 2016 9:23 am  

Bonjour,

pourriez vous me communiquer votre nom de domaine ?
Sylvain
Service technique LWS
http://www.lws.fr

Rubrique d'aide LWS : http://aide.lws.fr
Les nouveautés : http://blog.lws-hosting.com

Noms de domaine, hébergement web, serveurs dédiés, e-commerce, SMS par internet ...

Jules66
Débutant
Débutant
Messages : 3
AntiSpam : - Non -

ven. janv. 15, 2016 9:26 pm  

nom de domaine : sv-leda.fr

Avatar de l’utilisateur
Sylvain - LWS
Modérateur
Modérateur
Messages : 674
AntiSpam : - Non -

lun. janv. 18, 2016 10:41 am  

Bonjour,

pour résoudre ce type de souci il faudra utiliser l'encodage ISO (europe centrale) au niveau de votre site web.
Je me permet de vous communiquer une documentation sur cela :
http://www.alsacreations.com/astuce/lir ... teres.html

Depuis un logiciel d'édition de type Notepad ++ il est possible de modifier l'encodage d'une page directement.
Sylvain
Service technique LWS
http://www.lws.fr

Rubrique d'aide LWS : http://aide.lws.fr
Les nouveautés : http://blog.lws-hosting.com

Noms de domaine, hébergement web, serveurs dédiés, e-commerce, SMS par internet ...

Jules66
Débutant
Débutant
Messages : 3
AntiSpam : - Non -

jeu. janv. 21, 2016 10:59 pm  

Bonjour,

J'ai résolu une partie de mon problème en passant par Wordpress. J'arrive sans aucun problème à rédiger des pages, mais lorsque je souhaite importer des données de ma base, les caractères avec accent se transforment en "?".
Tout se passe comme si les données venant de la base arrivaient avec le mauvais charset...
Je n'arrive pas à tout synchroniser...

Avatar de l’utilisateur
Sylvain - LWS
Modérateur
Modérateur
Messages : 674
AntiSpam : - Non -

ven. janv. 22, 2016 10:37 am  

Sylvain
Service technique LWS
http://www.lws.fr

Rubrique d'aide LWS : http://aide.lws.fr
Les nouveautés : http://blog.lws-hosting.com

Noms de domaine, hébergement web, serveurs dédiés, e-commerce, SMS par internet ...

  •   Information
  • Qui est en ligne ?

    Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 2 invités