Forum : Lws & Hebergeur-discount

Hébergement web, nom de domaine et serveur dédié.

me suis mis l'index dans l'oeil!!

Ici vous pouvez poser vos questions techniques, les problemes que vous rencontrez (publication de votre site, configuration dns des domaines...)
kykio

mar. févr. 14, 2006 9:09 pm  

Excusez moi je suis novice.....où met-on l'index.html????Au fait mon site est "lepointbar.com".....si je vais sur le net et que je cherche mon site ,il est dit:"site en construction",si je cherche mon site en ajoutant http://www.lepointbar.com/index.html ;eh ben ça marche.Mais juste http://www.lepointbar.com ;ça marche pas!! (ou alors c'est normal..)
J'ai essayé d'enlever index.htm comme vous l'indiquez dans le tutoriel...rien;j'ai retenté;rerien!!
Je me sers de NVU.
J'ai (avec filezilla) installé mes dossiers et autres pages dans "htdocs".Cela fonctionne puisque quand j'entre un chemin (http://lepointbar.com/fonds/kekchozz.jpg) pour trouver une texture de fond,eh bien je trouve.
Alors je ne sais pas...J'ai dû faire une couannerie ...mais où?? Et je dois répéter l'erreur à chaque fois!! Rigolez pas trop...........
Merci d'avance.[/b]

istrya
Expert
Expert
Messages : 303

mer. févr. 15, 2006 10:07 am  

Salut,
Apparement, tu as corrigé le problème entretemps, puisque ton site fonctionne à merveille.
Mais quelques informations pour le fichier index.html :
- Tu peux le mettre dans n'importe quel répertoire ( en commençcant dans htdocs, bien sûr ).
- Il sera ouvert automatiquement ( au lieu de taper http://www.monsite.com/repertoire/index.html, tu taperas http://www.monsite.com/repertoire ( <- avec ou sans / [slach] à la fin ) )
- Si tu pointes sur un répertoire où il n'y a pas de fichier index.html, tu auras une pages d'erreur disant que le répertoire est interdit ( exemple, dans le répertoire repertoire il n'y a pas de fichier index.html et tu tapes l'adresse www.monsite.com/repertoire, tu auras une erreur... ). Par contre, tu n'auras pas cette erreur si tu pointes vers un fichier existant dans le répertoire ( par exemple, dans le même répertoire repertoire, tu as mis un fichier coucou.html, tu taperas alors www.monsite.com/repertoire/coucou.html ).
- Finalement, ce qui est dit au-dessus peut changer, car certains hébergeur , lorsqu'il n'ya pas de fichier index.html , liste le répertoire. Mais il est plus interessant au niveau sécurité qu'on ne puisse pas lister un répertoire, pour cacher certains fichier. On peut aussi obliger certains dossier à être caché et protégé...

Note : les fichiers d'index peuvent avoir d'autres extensions au lieu de .html, comme par exemple index.php, index.php3, default.asp ( pour pas qu'il n'y est de conflit, les index sont pris en compte dans un certain ordre ).

kykio

mer. févr. 15, 2006 1:10 pm  

Ok; merci!!! Je vais essayer de continuer et de m'en sortir avec le reste;les mails ;et tout le bazar....Dès que ça coince,je crie au secours!!
Merci encore;et à plus tard.

kykio

mer. févr. 15, 2006 1:58 pm  

C'est encore moi...........y'a un os;malgré ta réponse et le fait que tu me dises que mon site fonctionne;eh ben,quand je fais "visualiser votre site" on me répond encore que mon site est en construction!!!!! Et pareil si je tape http://lepointbar.com Il faut que j'ajoute quelque chose après le ".com" sinon,:"le site est en construction" à chaque fois... Je dois être obtus!!
J'étais persuadé que http://lepointbar.com suffisait......et c'est peut-être là que je me trompe non??
Merci pour ta patience.

istrya
Expert
Expert
Messages : 303

mer. févr. 15, 2006 4:16 pm  

Salut,
Je pense que ça vient du cache de ton navigateur ( les pages sont stockés dans la mémoire de l'ordinateur pour éviter de devoir recharger la page à chaque fois). Pour le vider, suis ce que je dit plus bas:

-Pour les utilisateurs d'Internet Explorer:
_Ouvrez internet explorer
_ Allez dans Outils > Options Internet...
_ Cliquez sur Supprimer les fichiers
_ Allez sur le site

-Pour les utilisateurs de Firefox :
_ Ouvrez Firefox
_ Allez dans Outils > Options
_ Allez dans l'onglet Vie Privée
_ Allez - dans le même onglet - dans l'onglet Cache
_ Cliquez sur vider le cache
_ Allez sur le site

Voilà, si ça ne marche pas, contacte un technicien de HD via le panneau d'administration.

kykio

mer. févr. 15, 2006 8:39 pm  

Merci pour les conseils........mais le coup du cache des fichiers temporaires a foiré.tant pis;donc j'ai envoyé un "ticket" où je pose la question........on verra bien.
Merci encore et je te ferai part de la réponse.
A+

  •   Information
  • Qui est en ligne ?

    Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 3 invités